WordPress Security and why you should care


Like many modern software packages, WordPress is updated regularly to address new security issues that may arise. Improving software security is always an ongoing concern, and to that end you should always keep up to date with the latest version of WordPress. Older versions of WordPress are not maintained with security updates.

We strongly advise ALL our clients who have WordPress blogs or sites to take security very seriously.  After all it is the most widely used platform on the planet.  We have in recently put together a Security WordPress Program in place which tackles this issue and ensures that your WordPress website is up to date and most importantly secure keeping hackers at bay.

We do regular monitoring to ensure you are running the latest version of WordPress and install them.

We keep plugins up to date, as most tend to get out-dated quickly. It’s vital that you use well known and updated trusted plugins from reliable sources.

We then install, configure and run Security plugins to tighten up security. Many steps are taken to ensure we keep the bad guys out and you in control.

One of the easiest things to do is change where you actually login. Typically on a /blog/wp-admin page. This gets changed to something unique. If you hide your login page, that’s half the battle. Of course there are many steps we do during our configuration process.

+ Learn More About our Service Here